Volkswagen T-Cross Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Again this seems a common problem especially when it is a cold morning.
It is interesting to note that on my car the dashboard is fitted completely flush to the A pillar on the drivers side!.
It is only on the passenger side where there is a gap to the r pillar! (photo attached).
Yes as soon as the car is warmed up the clicking noise stops and never returns during the rest of the day.
It clearly makes sense as a long term measure in asking the dealership to put some padding down the gap to avoid any friction/noise.
I have also sprayed a very small amount of Autoglyn rubber and vinyl care into the small area which has also solved the problem.
Again I hope this post is useful.
 

Attachments

·
Registered
Joined
·
156 Posts
Yep, very easy to solve yourself..

I just got a small piece of an old black rubber floor mat, cut off a small slice, and jammed it down the gap, leaving a bit sticking up in case I wanted to remove it.

Once I knew that the noise had gone, I carefully cut of the excess so it couldn't be seen.

Sorted !!
 

·
Registered
Joined
·
88 Posts
I had previously packed it out, and later the dealer put extra packing in.
Strangely it has started to give the occasional 'crack' noise, perhaps because of the hot weather.
No real problem, now looking around for a bit of black rubber to poke in. Best not to press in too far as it disappears inside!
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top