Volkswagen T-Cross Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
The ECP light has just come on in my T Cross automatic, it is only 6 month old and has done 5000 miles. I can't take it into a dealer for about 4 or 5 days. That's if I can even get it booked in. Would it be safe to drive? I will only be doing about 60 miles over the next few days. I drove home from work and it runs fine at the moment
Thanks
David
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #2 ·
Sorry see the above message it is not the EPC light on but the yellows engine light staying on. According to the manual it's an exhaust system fault or emissions relevant fault. Still don't know if I can drive it
 

·
Registered
Joined
·
88 Posts
I had a similar temporary fault with the engine light on my Golf. Took it into the dealer and the diagnostic advised a fuel pressure fault. They cleared it and it disappeared. Maybe something similar; I'd drive it for the short distance that you indicate. Cheers-John
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #5 ·
I will ring them. Unfortunately I couldn't ring them today as the dealer was closed by the time I got in from work. Looks like I will have to use the motorbike till its sorted
 

·
Registered
Joined
·
19 Posts
I also had the EPC light come on the other day. When ì started the car, an error light came on in the centre of the screen saying 'error stop stařt'. It flashed off again but the epc light started on. Wasn't sure what to do but had an urgen medical appointment in half an hour. I decided to attempt to drive to my appointment 6 kms away. All OK getting there, and i rang the dealer to tell them the situation, and said i would bring the car in next day. When i started the car up to go home 5 hours later, the same error message came up with the EPC łight as well.
Before i had driven- 1 km, the EPC light went off and i haven't seen it since. I rang the dealer and told them i wouldn't be coming in as there wasnt a problem now. I figured that they can't find the problem if there is nothing showing on the dash. I have just put it down to a hiccup. So many electronics, but this is the age we live in.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top