Volkswagen T-Cross Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hi everyone,
So far very happy with the T-Cross. I did notice one thing though and wondered if it's normal. When manoeuvring with full steering lock (both left and right) I'm hearing a rubbing/grinding? noise. Has anyone else noticed this?
Thanks!
 

·
Registered
Joined
·
14 Posts
Just a thought!
Had the same with a Peugeot but not always...
It came out to be that the garage surface made tires giving a sound like rubbing/grinding to the very end of steering lock...
Sound looked like it was from engine bay but it was reflection of sound because it was underground garage...
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #5 ·
It's happening whenever I'm manoeuvring with a full steering lock eg in carpark or doing 3-point turns in the road. The car's booked in for later this month. I'll update with the dealer's response after that.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #6 ·
Just wanted to post an update on this. As usually happens the car didn't make the noise at the dealership! However a technician suggested that there might be a cleaning cycle whereby the brake pads are held against the discs. I'm not sure why the noise would only be heard with a full steering lock in this case. Will keep an eye on it and post any updates. Thanks everyone.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top