Volkswagen T-Cross Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Just received new tcross last week and could not register as the primary user just got a message to contact customer support. I called them and they advised it's a known issue that has to be resolved at the dealership which they arranged. However I am curious has anyone else seen this issue? I'll try to find more specific information when I'm at the dealership.
 

·
Registered
Joined
·
127 Posts
Hiya

I collected my T-Cross about 10 days ago and haven't seen the issue. I set my account up on the computer at home, rather than creating it in the car, so it was just a case of typing in the email address and password, then assigning myself to the primary user account which seemed to be straightforward. Not sure if its worth trying it that way round ?

The only thing I can't seem to get to work is the lock/unlock option from the WeConnect app which tries to connect to something which I cancelled then comes up with something about verifying my identity at the dealer. Isn't necessarily something I would use as I can't think of a scenario where I wouldn't have my keys with me to open the car.

Hope you manage to get it sorted

N
 

·
Registered
Joined
·
17 Posts
Hi to all. Having received my TCROSS on December 05, 2020, I set up my account using my home computer. I then tried to do the primary user activation using the 2 keys, but to my dismay it didn't work. My user appears as a normal user, but not the primary user. I contacted the dealership and even went over to their service center, but was told that I would have to leave the car in for about 3 days for them to sort it out. I contacted customer service twice about this, and a case was opened so that the correct steps and info be sent to the dealership. I am still waiting for customer service to email me on how to proceed. I love my little Tcross, but to be honest, I didn't expect this type of problems from VW. Makes me wonder if I made the right decision. I mean even KIA and Hyundai don't have such stupid issues.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top