Volkswagen T-Cross Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hi. I have a T-Cross, 3 months old, today I went to vac it and found the carpet in the rear footwell (drivers side - UK) was ringing wet. The top of the floormat is dry. I have thrown a bucket of water at the door to see if any seeped in - it didn't, so the seals look to be ok and it looks like the water is getting in from the underneath. I have taken it to a car wash once (one I regularly used with my old car) before Christmas. Someone was in the back of the car at the time and nothing was noticed. The rear wash/wipe still works so doesn't seem to indicate a disconnected pipe. I have booked it into the dealers for next week, but has anyone else experienced this, or have any ideas. I'm a bit disappointed at the thought they may have to get all the carpet up on a brand new car. Thanks.
 

·
Registered
Joined
·
394 Posts
That sounds unusual...can’t imagine how the carpet got wet but not the mats, unless it’s been like that for some time.. Be interesting to know if your Dealer finds a leak.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
That sounds unusual...can’t imagine how the carpet got wet but not the mats, unless it’s been like that for some time.. Be interesting to know if your Dealer finds a leak.
I'll let you know. I keep paper mats on top of the floor mats in the winter as it's muddy where I live and the paper mat is dry so it has to be coming up through the carpet from underneath or somehow dribbling in from the door but as I said, I've chucked a bucket of water at the door and can't see anything seeping in. It's very disappointing as otherwise I'm very pleased and think it looks great in the new Ascot Grey colour.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
Been back to the dealer today, they said a seal was half off, so have dried it all out and reattached seal. Will have to see in due course if this is solved, hopefully it is, if not I'll report back.
 

·
Registered
Joined
·
66 Posts
Had same issue on an old Megane 2, the mat was bone dry but underneath the carpet the sponge and the floor liner were soaked. The culprit was the lower door seal not touching the door in the right places so the water was seeping in underneath the plastic sill trim into the foot well so you could not really see it unless you lift the mat. To resolve I had to readjust the lower door seal and no issues since then.
 
  • Like
Reactions: Halin9
1 - 5 of 5 Posts
Top