Volkswagen T-Cross Forum banner
1 - 20 of 27 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
I have a T-cross, R-Line 1.0 TSI (manual) which is great apart from a windscreen wiper judder.
The dealer has changed the wipers but still it happens - Just wondered if anyone else had suffered with this and if they had found a solution??
 

·
Registered
Joined
·
46 Posts
In order to avoid new topic!

At the time of wiper start and end, if I am descriptive, I hear a click sound somewhere between steering column and switch on/ off lights knob. When music is on, I can barely hear it. But when music is off I hear these weird click sounds.
Do you believe that it is normal?
 

·
Registered
Joined
·
65 Posts
That's the wiper relay, and yes, it's normal.

-eelis-
 

·
Registered
Joined
·
1 Posts
I too have the same problem. The garage have told me to wash the windscreen and wipers with neat screen wash. Am now waiting for rain to see if it has worked.
I note it has been suggested to wait for the wipers to bed in, how long does bedding in take?
 

·
Registered
Joined
·
7 Posts
We had the same problem when we picked up the car,I cleaned the wiper blades which looked to have grease or some protective material which had not been removed before delivery.also washed the screen ,it now seems ok.another problem is the poor screen jets probley partially blocked will clear them later.
 

·
Registered
Joined
·
313 Posts
And have wiper judder 😂 makes me feel part of the club lol
After reading here i try cleaningbthe blades. The screen has already been treated.
 

·
Super Moderator
Joined
·
462 Posts
Yes I hear the click also. Mildly irritates me as my Tig has auto supers and it doesn't have the click.
 

·
Registered
Joined
·
30 Posts
This has been a problem with the 2018 Polo wiper blades, juddering. Not sure if the T-Cross has the same size blades as the Polo? but many of the Polo forum have replaced them with the following and has cured 98% of the juddering.

https://www.ebay.co.uk/itm/Bosch-Aerotwin-Front-Wiper-Blades-Set-650-450mm-26-18-3397007864-A864S/153030885585

Did you have them clean your car before you took it away, the last time I had a service, they washed it, that's the first and last time I let them do that, the first time I turned on the wipers, it juddered, I took it home and spent a good half an hour cleaning what ever they used to clean the windows. All is fine now!!

If the blades are the same size, get a set, you won't find them cheaper anywhere else.
 

·
Registered
Joined
·
7 Posts
I have had the same on my 2017 Up from new annoyingly I have just had to replace them because the rubber split just couldn't hang on a few more weeks for my t cross to come. I replaced them with the Bosch's aero twin wipers and they are now perfect wish I changed them earlier. If my t cross is the same I will definitely replacing them
 

·
Registered
Joined
·
81 Posts
After having my car done with cquartz the guy who did it said they put window treatment on ... I'm sure this is causing my wiper judder as it's fine when using the car screen wash . After attempting to clean window with meths(doesn't work )I've now tried white vinegar which the detailer recommends... now where's that rain 😳
 

·
Registered
Joined
·
77 Posts
Our T-Cross had a similar thing, we went for a long drive down south just after we got it and it rained a far bit, and the wipers were annoyingly juddery.

More recently (couple of months later) they are much much better, no noticeable judder at all and we haven't done anything to the wipers or the windscreen, it just seems that the wipers need a little time and use to soften up and settle in.
 

·
Super Moderator
Joined
·
462 Posts
The wipers still speak on our cross, 8 months on. Never had it on the Tig, UP! or Polo. Maybe where they source the parts from as the Cross is built in Spain, the Polo was South Africa and the Tig Germany and UP! I think Czech republic.
 

·
Registered
Joined
·
81 Posts
Vw just suggested I clean blades with white vinegar.doh I've already done that . Still I ll do it again but pretty sure it's the cquartz screen covering that's causing this . Anyway the detailer said he would fix it but try vinegar a couple more times he said if it's no better he would remove the coating by another method .wiper works fine on screen wash which leads me to believe it's the coating. . Anyone who's thinking about having a ceramic coating on their car it may be an idea to avoid the windows ....
 

·
Registered
Joined
·
65 Posts
No coating in my wifes windscreen but the wipers still judder on it.

This is purely down to VW using a cheaper supplier.

Anyone know a good set of none VW replacements?
 
1 - 20 of 27 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top